Website Migration
Incident Report for CTO.ai Platform
Resolved
This incident has been resolved.
Posted Oct 08, 2020 - 20:33 PDT
Monitoring
We are migrating out website and don't expect any downtime. Our Support team is on call the help you with any issues.
Posted Oct 08, 2020 - 17:06 PDT
This incident affected: Platform Services.